Macworld Forums

Macworld Forums: Screenshot location/permissions problem - Macworld Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Screenshot location/permissions problem MacOSX refuses to let me store a screenshot. Permission problem.

#1 User is offline   fjpoblam 

  • Member
  • PipPip
  • Group: Members
  • Posts: 77
  • Joined: 04-May 08

Posted 23 November 2009 - 08:37 PM

When I use command+shift+4, then outline a screen area for a snapshot, the shutter whirrs and clicks. Then this message pops up: "Your screen shot can't be saved. You don't have permission to save files in the location where screen shots are stored."

I have no idea what location this may be. Nor have I any idea how to go about either changing the location or changing my permission to access the current location.

I'm an old Windoze veteran, only about a year-old MacOSX user. So, guesswork: I ran the disk utility to repair permissions, but I suspect this is hardly relevant.

I'm running a MacBookPro, 10.6.2, scrupulously up-to-date.

This post has been edited by fjpoblam: 23 November 2009 - 08:40 PM

0

#2 User is offline   bastion 

  • Power User
  • PipPipPipPip
  • Group: Members
  • Posts: 9,272
  • Joined: 14-October 04

Posted 25 November 2009 - 09:18 AM

View Postfjpoblam, on 23 November 2009 - 08:37 PM, said:

When I use command+shift+4, then outline a screen area for a snapshot, the shutter whirrs and clicks. Then this message pops up: "Your screen shot can't be saved. You don't have permission to save files in the location where screen shots are stored."

I have no idea what location this may be. Nor have I any idea how to go about either changing the location or changing my permission to access the current location.

I'm an old Windoze veteran, only about a year-old MacOSX user. So, guesswork: I ran the disk utility to repair permissions, but I suspect this is hardly relevant.

I'm running a MacBookPro, 10.6.2, scrupulously up-to-date.


By default screenshots are stored on the desktop. So it sounds like you don't have permission to change the contents of ~/Desktop. That would be rather weird. As a simple test, but i really don't know how definitive it will be, just click on your desktop (so no other windows are active) and then press Cmd-Shift-N to (try to) create a new folder. It would also be instructive to open a terminal window (which should have its working directory set to your home by default) and type ls -la to see what the permissions are on the various folders in your home directory.
0

#3 User is offline   brompus 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 10-January 10

Posted 10 January 2010 - 05:07 AM

View Postbastion, on 25 November 2009 - 09:18 AM, said:

View Postfjpoblam, on 23 November 2009 - 08:37 PM, said:

When I use command+shift+4, then outline a screen area for a snapshot, the shutter whirrs and clicks. Then this message pops up: "Your screen shot can't be saved. You don't have permission to save files in the location where screen shots are stored."

I have no idea what location this may be. Nor have I any idea how to go about either changing the location or changing my permission to access the current location.

I'm an old Windoze veteran, only about a year-old MacOSX user. So, guesswork: I ran the disk utility to repair permissions, but I suspect this is hardly relevant.

I'm running a MacBookPro, 10.6.2, scrupulously up-to-date.


By default screenshots are stored on the desktop. So it sounds like you don't have permission to change the contents of ~/Desktop. That would be rather weird. As a simple test, but i really don't know how definitive it will be, just click on your desktop (so no other windows are active) and then press Cmd-Shift-N to (try to) create a new folder. It would also be instructive to open a terminal window (which should have its working directory set to your home by default) and type ls -la to see what the permissions are on the various folders in your home directory.


____________________________________

Okay look, heres what you do. Go to Finder and click your Username (under Places should be Desktop and then your username). Click that and then you will see all these folders like Desktop, Documents, etc. The problem you are experiencing is most probably because your desktop is locked. If you look at the the desktop folder in the finder, look at the bottom left. there is a silver lock, that is the problem. to fix it, control click or right click or whatever on it and then click Get Info. Once you click get info, on the bottom right should be a small gold colored lock. click that, it will prompt you for admin password, type it in. Then you are allowed to make changes. On the panel that you clicked the lock on, there should be two options which you can click or not click. There is Shared Folders and Locked. Your problem that you have is probably because of the Locked thing having a check on the left of it. If you uncheck that, it should fix the problem. Then go to the bottom of the panel. Look at the little section. It should have your user name on it and to the right it should say Read & Write. If it doesnt, click it and click the Read & Write. This should solve the problem. Any other questions, email me. metrokick@hotmail.com

:D
0

#4 User is offline   Anahaw 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 13-March 10

Posted 13 March 2010 - 03:01 AM

I had the same problem since I bought this iMac on December 2009. It says also "You do not have permission to save on the location......."

Thanks ALL, brompus, bastion. It turned out my Desktop was "Locked". I followed your instruction Brompus and it worked out finally.

FINDER > USER > DESKTOP > drop down to GET INFO > AND ON THE GENERAL TAB and uncheck the LOCKED feature and thats it!!



Thanks Guys
0

#5 User is offline   StevenStanley 

  • Newbie
  • Pip
  • Group: New Members
  • Posts: 1
  • Joined: 19-April 12

Posted 19 April 2012 - 06:14 PM

You might also see this message if you rename your Desktop folder accidentally, like I did yesterday when cleaning my keyboard...

Oh, and unplug your keyboard before cleaning it... ;-)


.:S:.
0

#6 User is offline   queenart88 

  • Newbie
  • Pip
  • Group: New Members
  • Posts: 2
  • Joined: 02-May 13

Posted 02 May 2013 - 04:55 AM

you may go to FINDER, click on the sidebar "DESKTOP", GET INFO. See below "SHARING & PERMISSION". Find below your username, and change the privilege to "READ and WRITE". That way you can access again the PRINT SCREEN mode.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users