Macworld Forums

Macworld Forums: Apple's fix for Do Not Disturb 2013 woes: Wait until Jan 7 - Macworld Forums

Jump to content

  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Apple's fix for Do Not Disturb 2013 woes: Wait until Jan 7

#1 User is offline   Macworld 

  • Story Poster
  • Group: MW Bot
  • Posts: 34,402
  • Joined: 30-November 07

Posted 02 January 2013 - 10:58 AM

Post your comments for Apple's fix for Do Not Disturb 2013 woes: Wait until Jan 7 here
0

#2 User is offline   Padgeman 

  • Newbie
  • Pip
  • Group: New Members
  • Posts: 2
  • Joined: 08-December 11

  Posted 02 January 2013 - 11:07 AM

I wonder what happens on January 7th. I was very grateful that it stayed on on January 1st, wasn't looking forward to being woken up by email!
0

#3 User is offline   AndrewRodney 

  • Member
  • PipPip
  • Group: Members
  • Posts: 268
  • Joined: 19-July 05

  Posted 02 January 2013 - 11:55 AM

DND could be a great feature when working properly but I still don't get the original non buggy behavior. I want DND on every day from say 8pm to 7am. I have to set it to be on every day. What a drag. The new bug keeps DND ON which is what it should do once set but of course, outside the hours set, it should allow calls and such to come through. But why oh why do I have to go into Settings every day to turn it on? What's Apple thinking?
Andrew Rodney
Author “Color Management for Photographers”
http://digitaldog.net/
0

#4 User is offline   jdb8167 

  • Veteran
  • PipPipPip
  • Group: Members
  • Posts: 2,584
  • Joined: 30-August 04

  Posted 02 January 2013 - 01:18 PM

Quote

DND could be a great feature when working properly but I still don't get the original non buggy behavior. I want DND on every day from say 8pm to 7am. I have to set it to be on every day.

Maybe I'm misunderstanding but once you set the schedule, it will automatically set DND without requiring any input on your part. The bug is that the DND is not turning off on schedule without manual intervention.

If you manually turn DND off after it has been scheduled, it will remain off until you set the switch back to the on position or until the next day when it should turn itself back on. (I haven't tested this but since I got hit by this bug, I'll find out tonight.)

EDIT: Maybe you are confused on how to set the schedule? If so, it is under Notifications, the next setting line after the DND switch.

This post has been edited by jdb8167: 02 January 2013 - 01:26 PM

0

#5 User is offline   AndrewRodney 

  • Member
  • PipPip
  • Group: Members
  • Posts: 268
  • Joined: 19-July 05

  Posted 02 January 2013 - 02:29 PM

>Maybe I'm misunderstanding but once you set the schedule, it will automatically set DND without requiring any input on your part.

It sets itself for one day. The next day, it defaults to OFF. So what I'd like is to set it and forget it. It stays on until I turn it off. IOW, each day, the moon icon dismisses itself and DND is in off mode. I did set a schedule for the time I want DND to operate. That's working fine. What I don't want to do is have to turn it on every day in Settings.
Andrew Rodney
Author “Color Management for Photographers”
http://digitaldog.net/
0

#6 User is offline   TheTSArt 

  • Member
  • PipPip
  • Group: Members
  • Posts: 269
  • Joined: 19-February 04

  Posted 02 January 2013 - 03:23 PM

Quote

>Maybe I'm misunderstanding but once you set the schedule, it will automatically set DND without requiring any input on your part. It sets itself for one day. The next day, it defaults to OFF. So what I'd like is to set it and forget it. It stays on until I turn it off. IOW, each day, the moon icon dismisses itself and DND is in off mode. I did set a schedule for the time I want DND to operate. That's working fine. What I don't want to do is have to turn it on every day in Settings.


Mine is set for DND everyday from 12 am - 7 am. It does it automatically every single day, I never turn it on or off manually.
0

#7 User is offline   Nansue 

  • Newbie
  • Pip
  • Group: New Members
  • Posts: 1
  • Joined: 02-January 13

  Posted 02 January 2013 - 04:10 PM

Quote

>Maybe I'm misunderstanding but once you set the schedule, it will automatically set DND without requiring any input on your part. It sets itself for one day. The next day, it defaults to OFF. So what I'd like is to set it and forget it. It stays on until I turn it off. IOW, each day, the moon icon dismisses itself and DND is in off mode. I did set a schedule for the time I want DND to operate. That's working fine. What I don't want to do is have to turn it on every day in Settings.


I think you may be confusing Settings/DND with Settings/Notifications/DND. The current bug aside, when you schedule DND in Notifications it will turn DND on and off at the scheduled times. Settings/DND will show as off except during the time period you have scheduled.
0

#8 User is offline   AndrewRodney 

  • Member
  • PipPip
  • Group: Members
  • Posts: 268
  • Joined: 19-July 05

  Posted 02 January 2013 - 04:21 PM

>>when you schedule DND in Notifications it will turn DND on and off at the scheduled times. Settings/DND will show as off except during the time period you have

Thanks, I'll try that, despite the new bug (which I did notice today).
Andrew Rodney
Author “Color Management for Photographers”
http://digitaldog.net/
0

#9 User is offline   dominiquejames 

  • Member
  • PipPip
  • Group: Members
  • Posts: 192
  • Joined: 23-January 07

  Posted 02 January 2013 - 07:36 PM

I was late for work today because of this DND bug. My TouchLCD alarm did not go off.
0

#10 User is offline   gdonners 

  • Newbie
  • Group: Macworld Insiders
  • Posts: 2
  • Joined: 14-December 11

  Posted 02 January 2013 - 10:08 PM

Maybe Apple should trade some lawyers for developers.
0

#11 User is offline   TheHeeNow 

  • Member
  • Group: Macworld Insiders
  • Posts: 152
  • Joined: 06-December 10

  Posted 03 January 2013 - 07:19 AM

I think I'm also confused. To work as advertised, disregarding bug, should

Settings > DND be On or Off if Settings > Notifications > DND is set to ON per schedule?

Thanks
0

#12 User is offline   meade78 

  • Member
  • PipPip
  • Group: Members
  • Posts: 16
  • Joined: 29-July 08

  Posted 03 January 2013 - 09:42 AM

What I want to know is if government alerts will override DND. I have my phone set to receive them, and had a tornado warning come over it once. There was no question that I had to pick it up. It would be really useful if you could use DND, but still have something like that wake you in the middle of the night.
0

#13 User is offline   AndrewRodney 

  • Member
  • PipPip
  • Group: Members
  • Posts: 268
  • Joined: 19-July 05

  Posted 03 January 2013 - 11:17 AM

>>when you schedule DND in Notifications it will turn DND on and off at the scheduled times. Settings/DND will show as off except during the time period you have

Well it still doesn't work correctly bug aside (and the bug hit me again this morning).

Turn ON DND it only works one day, then turns itself off. One cycle. IF DND is OFF but Notification for it is ON, DND doesn't work (I still get alerts).

It appears that besides the bug discussed here, the design of DNG is you have to set the notification to the hours you want it to run, but you also must set it to be on. It runs once but turns itself off the next day, when this silly bug isn't affecting it.

It almost seems like this was some kind of feature change that didn't develop correctly. Having DND 'stay on' and repeat every day is working in some respects, thanks to the bug, it just doesn't understand the hours setup in the notification. What the feature should do is this: You set the times you want DND on (8-8), but you don't have to set it to on every day.
Andrew Rodney
Author “Color Management for Photographers”
http://digitaldog.net/
1

#14 User is offline   AppleKiwi 

  • Newbie
  • Pip
  • Group: New Members
  • Posts: 13
  • Joined: 07-June 11

  Posted 03 January 2013 - 02:25 PM

Quote

>>when you schedule DND in Notifications it will turn DND on and off at the scheduled times. Settings/DND will show as off except during the time period you have
Well it still doesn't work correctly bug aside (and the bug hit me again this morning).
Turn ON DND it only works one day, then turns itself off. One cycle. IF DND is OFF but Notification for it is ON, DND doesn't work (I still get alerts).
It appears that besides the bug discussed here, the design of DNG is you have to set the notification to the hours you want it to run, but you also must set it to be on. It runs once but turns itself off the next day, when this silly bug isn't affecting it.
It almost seems like this was some kind of feature change that didn't develop correctly. Having DND 'stay on' and repeat every day is working in some respects, thanks to the bug, it just doesn't understand the hours setup in the notification. What the feature should do is this: You set the times you want DND on (8-8), but you don't have to set it to on every day.


I still think you're a bit confused...

The schedule will switch DND off and on... if you set up the schedule, it won't switch DND on until the time you have set arrives, and once you're in the schedule zone, you can disable it manually...

Quote

What I want to know is if government alerts will override DND. I have my phone set to receive them, and had a tornado warning come over it once. There was no question that I had to pick it up. It would be really useful if you could use DND, but still have something like that wake you in the middle of the night.


I think what you want here (i.e. the ability of a government around the world to override your smartphone settings) isn't what the vast majority of people want! But, it would make some sense to be allowed to allow exceptions to the rule that YOU can control.
0

Share this topic:


  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users