Macworld Forums

Macworld Forums: Don't Have enough Access Privileges to download from Itunes store? - Macworld Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Don't Have enough Access Privileges to download from Itunes store?

#1 User is offline   tudacee 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 7
  • Joined: 04-August 04

Posted 13 January 2008 - 09:29 PM

Just got a Macbook Pro with Leopard 10.5.1, which I love...everything seems to work, except the iTunes and downloading from the store...
Here's what happened:
I used an ethernet connection to transfer iTune files from the desktop mac to
the macbookpro. I then put the files into the User/Music/Itunes/ITunes
Music folder. I opened up ITunes and authorized the laptop to be able
to see and use the transferred music, movies and podcasts. That went
fine, and I can see and use them, and so can my ipod.
However, when I went to update a podcast, I got an error message. Same
thing when I tried to download a song, and again a freebie Lost show.
This is what came up as to why it wouldn't download:
>>There was a problem downloading...
You do not have enough access privileges for this operation.
Please check the connection to the network is active and try again.>>
I thought maybe I need to set up a separate account on my new laptop, did that, and still keep getting the above message.
I use Airport to access the internet...and I haven't had any problems,
it works fine (using it now), so don't know what they mean by checking
the connection.

I've also used disk utility to repair permissions, but again, still have the same old problem.

Any help you can give would be appreciated.
thanks.
0

#2 User is offline   tudacee 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 7
  • Joined: 04-August 04

Posted 14 January 2008 - 02:16 PM

UPDATE



NOW when I tried to copy a .mov file into itunes this is the message I get, as well as the above problem:
Attempting to copy to the disk failed. You do not have enough access privileges fro this operation.
ITunes could not save to your Music folder because you do not have write access. Check the permissions on your Music Folder and folders in your Music Folder, then try copying this file again.



I've gone to the Info and it says I have read&write permission, and I've done a Disk Utility scan for permissions at least 2x.



Notice that there's been no response since I posted, hope that doesn't mean I'm out here in the cold! ;-(
0

#3 User is offline   kakubei 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 27-January 08

Posted 27 January 2008 - 04:38 AM

Hello, I found the solution!

1. Open iTunes
2. go to preferences
3. go to Advanced
4. Notice where your itunes library lives. By default this will be your home folder, then Music folder, but you can change it so be sure to note the route
5. Go to that folder where your itunes library lives and make absolutely sure you have write permissions to it AND THE FOLDERS ABOVE AND BELOW AS WELL.
6. This should do the trick.

If all else fails and you are desperate, and no one else uses your computer, you can try to make all the folders in your Music folders writable by anyone. Indeed, you could try making all of the folders in your user's home folder writable by everyone although I would not recommend it.

You can do this by getting info on the folder you want to change and then going to the permissions section, click the lock and set read and write permissions for "everyone".
0

#4 User is offline   marlon1985 

  • Member
  • PipPip
  • Group: Members
  • Posts: 180
  • Joined: 26-September 06

Posted 27 January 2008 - 09:41 AM

NO you are not left in the cold.....now I had a similar problem when I update to leopard, but after a couple of messages from Itunes online support they got me going, try apple.com and Itunes support and just send them a message, sorry if I can remember all the details......
0

#5 User is offline   locotiki 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 27-January 09

Posted 27 January 2009 - 06:45 AM

I'm having the same issue.

Everything started when I created a new user account for myself and moved my ituens library over to it.

Quick question..when you went through and made sure all the folders had read write permissions did you go through every artist folder in your "iTunes Music" parent folder or just the parent folders? I tired giving everyone "read write" in all the parent folders as it's just me and sometimes my wife who use this computer but I'm still getting the error.

Thanks!
0

#6 User is online   designchicklet 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 25-June 08

Posted 12 October 2009 - 11:12 AM

Hey there! I just had the same message and called Apple (especially that I purchased an iPhone app) and I wasn't able to download it. This is what you need to do:

Go to your iTunes Folder --> hit apple (command) I (Get info).
Make sure you unlock the folder if it's locked
Make sure you see your user under (Sharing & Permissions)
If you don't: Click the + sign, select your user, and give yourself Read & Write Permissions
If you do see yourself: give yourself Read & Write Permissions
Then click the pull-down gear button and make yourself the owner
Once again click the gear pull-down menu and click apply to enclosed items.

Give it a few secs, log-out from users and when you get back in it will work.

;-)

DesignChicklet
1

#7 User is offline   AndreonnaZielinski 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 14-April 10

Posted 14 April 2010 - 09:41 AM

View Postkakubei, on 27 January 2008 - 04:38 AM, said:

Hello, I found the solution!

1. Open iTunes
2. go to preferences
3. go to Advanced
4. Notice where your itunes library lives. By default this will be your home folder, then Music folder, but you can change it so be sure to note the route
5. Go to that folder where your itunes library lives and make absolutely sure you have write permissions to it AND THE FOLDERS ABOVE AND BELOW AS WELL.
6. This should do the trick.

If all else fails and you are desperate, and no one else uses your computer, you can try to make all the folders in your Music folders writable by anyone. Indeed, you could try making all of the folders in your user's home folder writable by everyone although I would not recommend it.

You can do this by getting info on the folder you want to change and then going to the permissions section, click the lock and set read and write permissions for "everyone".




I saw that you were having basically the same trouble as I was with iTunes. I got the error message "You don’t have write access for your iTunes media folder or a folder within it. To change permissions, select your iTunes Media folder in the Finder, and choose File>Get Info" I was searching the web and found this article that fixed my problem. Check it out it may help you too. It describes how with iTunes 9 the settings have changed. But describes it better than I can so I hope it helps you too. http://reviews.cnet....446968-263.html
0

#8 User is offline   thehand 

  • Member
  • PipPip
  • Group: Members
  • Posts: 21
  • Joined: 13-May 02

Posted 14 November 2010 - 05:43 AM

this issue just popped up yesterday up when purchasing some movies. thanks for pointing out the permissions fix on the media folder. I can see how the problem would occur if your moving you stuff to another drive or a new machine. That's happened to me in the past in both cases. What's strange about this latest occurrence is I wasn't doing any of that moving stuff. I was just buying stuff from the iTunes store. Any way I looked at the folder and found I wasn't even on the list. Now how could that be or how could that happen? I've purchased many and often up to this point. Well I added myself to the list and now my movies are downloading. I just want to know how I as admin user (I tried that standard user advice and found it's too much typing) was removed from the list or if I ever was and if I never was that how could have added all stuff and spent so many dollars to my library?

BTW there's a guy called system on that list and he has read AND write privileges. The minus sign is grayed-out for him.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users